Menu

Topic-icon Call to a member function setQuery() on null

  • Resident
  • Resident's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
1 month 1 week ago #9165 by Resident
Hi, if I try to update Control center from 2.2 to 2.3, I get an error: 
Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in/www/doc/www.......cz/www/libraries/vendor/joomla/filesystem/src/File.phpon line324

Joomla 4.0.5

Thank you 
Robert

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #9166 by Jose
Hi Robert,

But that message is related to Joomla, not to the Control center... I don't use Zend in my extensions...

The extension is fully tested in 4.1 and even 4.2 beta, but it should also work in 4.0. Did you try updating or installing other extensions?

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • Resident
  • Resident's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
1 month 1 week ago #9171 by Resident
Replied by Resident on topic Call to a member function setQuery() on null
Yes, I updated 7 extensions, including SecurutyCheck Pro and have this problem only with Control Center.
I will try Google if this is a Joomla problem, thank you Jose :-)

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #9172 by Jose
You're welcome Robert!

That file is a Joomla core file used during update process to manage cache. It seems the file passed to the "opcache_invalidate" function is null and this is why do you get the error...

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • Resident
  • Resident's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
1 month 1 week ago #9173 by Resident
Replied by Resident on topic Call to a member function setQuery() on null
Updated Joomla to 4.1.3 and still have the same problem with this one extension, ControlCenter. Other extensions updated normally....

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #9174 by Jose
Hi Robert,

Can you please send me administrative credentials to access to the backend? Please, use the email from which you receive forum notifications.

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.096 seconds
Powered by Kunena Forum

Login or Sign In