Menu

Topic-icon Malware and Integrity scans do not complete

  • margknox
  • margknox's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
1 month 1 week ago #8395 by margknox
On my primary site the malware scanner and integrity scan do not complete. I get a message that the last scan took too long to complete and I can't try again till I initialise data, which I do, but the scan still does not complete however long I leave it.

Now my host is telling me there's malware on my site.

What to do?

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #8396 by Jose
Hi margknox,

Maybe this is a memory issue. It's quite odd both doesn't end.

Try the following: go to Global Configuration -> Tuning and set the 'Scan executable files only' option to 'No'.

If that doesn't work check the log file generated on each task and add the latest file added as exception. Repeat it until the task end.

I can also have a look to the site if you send me administrative credentials to the email from which you receive forum notifications.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • margknox
  • margknox's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
1 month 6 days ago - 1 month 5 days ago #8420 by margknox
Replied by margknox on topic Malware and Integrity scans do not complete
Thank you Jose. The 'Scan executable files only' was already set to 'No' - However when I removed the very large file listed at the end of the Log, both scans completed. And reported no issues.

Regards,
Margaret
Last edit: 1 month 5 days ago by margknox. Reason: developments

Please Log in or Create an account to join the conversation.

More
1 month 6 days ago #8421 by Jose
Hi Margaret,

Be sure the malware scanner is configured to analyze the entire filesystem and look also for suspicious patterns (Global configuration -> Malware scan tab --> Deep scan enabled and Timeline set to "Anytime"). By default it only looks for known patterns in files modified a week ago.

If do you have multiple sites installed eveyr site must have its own Securitycheck Pro installed; we must not forget taht SCP is a Web Application firewall so it can't stop attacks directed against a subdomain with Joomla if it's installed only in the main site.

You can contact me privately to help you with this. Just write me to the email from which you receive forum notifications.

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum

Login or Sign In