Menu

Topic-icon Website blocked for me (Admin) and some Users because use wrong words

  • piper
  • piper's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 13 hours ago #7841 by piper
I could not log in to the website, my IP was blocked for a short time. In the firewall logs I could see that I have posted forbidden words in the forum. I wrote about the band "Dropkick Murphys" and the word "Drop" was blocked. But "Drop" is only a part of the word "Dropkick". How can I adjust this?

Please Log in or Create an account to join the conversation.

More
5 days 13 hours ago #7842 by Jose
Hi piper,

It should not block you unless there are 3 or more forbidden words (by default). You can adjust this into Waf configuration -> Second level protection tab.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • piper
  • piper's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 13 hours ago #7843 by piper
Okay, I found the list. It also says "drop", but can I set the blacklist to only contain single single words? In my case the word "dropkick" should not be forbidden.

Please Log in or Create an account to join the conversation.

More
5 days 13 hours ago #7844 by Jose
Yes, I should re-check this feature as it's configured to detect the word even if it's included into other word (this is a common trick of malware to be undetected). Is the rule applied even with the "Limit of suspicious words" dropdown set to 3?

I designed this feature just in case some attacks could avoid the sql and xss filters,which is not so frequent so if you have issues you can disable it.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • piper
  • piper's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 days 12 hours ago #7845 by piper
Yes the the "Limit of suspicious words" dropdown is set to 3, and the rule applied. Should I set to 5 or more?

Please Log in or Create an account to join the conversation.

More
5 days 12 hours ago #7846 by Jose
Yes, set it to 4 and if do you still have the issue disable this feature (as setting a higher value will be the same that disabling it). I promise to check this feature in future versions.

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.114 seconds
Powered by Kunena Forum

Login or Sign In