Menu

Topic-icon Update Issue

  • misholini
  • misholini's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
5 months 1 week ago #5916 by misholini
Update Issue was created by misholini
Hi,
I was running SCP 3.0.1 and the Liveupdate system did not show availability of new versions. Ended up downloading the latest 3.1.1 Pro and manually installing it.
There is an issue as all icons on the menus are gone (do not appear). I have attached a screenshot.
Also the System info shows 1 problem - "At least one HTTP security header is not configured. HTTP security headers provide yet another layer of security by helping to mitigate attacks and security vulnerabilities." (screenshot attached).
If this is result of non-configured Content-Security-Policy and Referrer Policy (print screen attached), how do I configure them.
Attachments:

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #5917 by Jose
Replied by Jose on topic Update Issue
Hi misholini,

The icons issue is caused by cache; just refresh your browser and/or clear your cache and everything will be ok.

Also the System info shows 1 problem - "At least one HTTP security header is not configured. HTTP security headers provide yet another layer of security by helping to mitigate attacks and security vulnerabilities." (screenshot attached).
If this is result of non-configured Content-Security-Policy and Referrer Policy (print screen attached), how do I configure them.

I have added several new headers to protect your site; some of them can be simply enabled or disabled, but others like Content-Security-Policy and Referrer Policy must be set by domain. I fear you have to read the hyperlinks and set them to suit your needs.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • misholini
  • misholini's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
5 months 1 week ago #5918 by misholini
Replied by misholini on topic Update Issue

but others like Content-Security-Policy and Referrer Policy must be set by domain. I fear you have to read the hyperlinks and set them to suit your needs.

Jose, Could you please explain what is means "set by domain" and do I need to configure these 2 security poilicy field.

Thanks!

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #5919 by Jose
Replied by Jose on topic Update Issue
I fear I made a mistake: I mean "set per domain". These headers must be set taking into consideration every domain: one setting can be valid for a domain but not for other.

For example, the "Referrer policy" Origin can cause redirections to main page after publishing a post in a forum (as the forum takes the referrer to redirect the page after publishing a post). This happened to me in my own domain, so I had to set it to a different value.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • misholini
  • misholini's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
5 months 1 week ago - 5 months 1 week ago #5920 by misholini
Replied by misholini on topic Update Issue
Thanks Jose! Setting this policies would require more technical knowledge. I hope security would not be hugely impacted without these.
Last edit: 5 months 1 week ago by misholini.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #5921 by Jose
Replied by Jose on topic Update Issue
You're welcome!

Don't worry; your site is still protected without those headers set :)

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.069 seconds
Powered by Kunena Forum

Login or Sign In