Menu

Topic-icon NGINX and htaccess protection: Change to phpfpm served by Apache

  • azurelinksc
  • azurelinksc's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
4 weeks 2 hours ago - 2 weeks 6 days ago #8999 by azurelinksc
Hola Jose!

Ran into an interesting problem today and I thought I would mention it here.
We recently upgraded our servers to the latest version of Plesk running on NGINX. As you know, when in the Options/htaccess protect tool, SCP displays a notice that NGINX does not support htaccess files. And the SCP interface displays a "Generate" button instead of the usual "Protect" button, and generates a text file with the htacess rules in it.

In my case, the fix was to change the PHP Settings for the domain in Plesk from "phpfpm served by nginx" to "phpfpm served by Apache".

After doing that, the "Protect" button came back and SCP applied the various rules to the htaccess file.

Maybe this will help someone. Not sure if it's worth adding the suggested change to your notice, or not.

Have a good day, and Happy New Year!

**** UPDATE ***
I noticed that the above change in Plesk was reverting back to "FPM served by NGINX". To overcome this, I had to also edit each vhost's Apache & NGINX setting, enabling Proxy Mode. And then re-apply the change of the FPM setting.
Last edit: 2 weeks 6 days ago by azurelinksc. Reason: Add new info.

Please Log in or Create an account to join the conversation.

More
4 weeks 1 hour ago #9002 by Jose
Hola azurelink!

Thank you very much for sharing this!!

I wish you a Happy New year! All the best for you and your family :)

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • azurelinksc
  • azurelinksc's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
2 weeks 6 days ago - 2 weeks 6 days ago #9017 by azurelinksc

Hola Jose!

Ran into an interesting problem today and I thought I would mention it here.
We recently upgraded our servers to the latest version of Plesk running on NGINX. As you know, when in the Options/htaccess protect tool, SCP displays a notice that NGINX does not support htaccess files. And the SCP interface displays a "Generate" button instead of the usual "Protect" button, and generates a text file with the htacess rules in it.

In my case, the fix was to change the PHP Settings for the domain in Plesk from "phpfpm served by nginx" to "phpfpm served by Apache".

After doing that, the "Protect" button came back and SCP applied the various rules to the htaccess file.

Maybe this will help someone. Not sure if it's worth adding the suggested change to your notice, or not.

Have a good day, and Happy New Year!

**** UPDATE ***
I noticed that the above change in Plesk was reverting back to "FPM served by NGINX". To overcome this, I had to also edit each vhost's Apache & NGINX setting, enabling Proxy Mode. And then re-apply the change of the FPM setting.

As an aside, while in the Apache & NGINX settings, deselect the "Restrict the ability to follow symlinks" checkbox. You've probably already noticed that because your Joomla site wouldn't run with it enabled. But thought I"d mention it anyway.

 
Last edit: 2 weeks 6 days ago by azurelinksc.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds
Powered by Kunena Forum

Login or Sign In