Menu

Topic-icon PHP8 Weird little problem

  • Dimps1
  • Dimps1's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 weeks 3 days ago #8871 by Dimps1
PHP8 Weird little problem was created by Dimps1
Hi Jose,
I have recently upgraded about 20 websites to PHP 8. SecurityCheck Pro 3.4.2 works fine on all of them except one. On this website, the WAF Configuration page has lost it's CSS and functionality. The pie chart of  Historical percentage of logs on the Dashboard is also missing. If I switch back to PHP7.4 - the pages display and function correctly. I have uninstalled and reinstalled SecurityCheck Pro without any success. I have also tried "fix database".
Any ideas?
Kind regards
Attachments:

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #8872 by Jose
Replied by Jose on topic PHP8 Weird little problem
Hi Dimps1,

For some reason the extension can't access to the css files or there is a cache issue. Did you try clearing your browser's cache and also enabling the developer tools of the browser to see what's happening?

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • Dimps1
  • Dimps1's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 weeks 3 days ago #8873 by Dimps1
Replied by Dimps1 on topic PHP8 Weird little problem
Thanks Jose,
Yes, and half the code inside the header tags was missing, but it was not a caching issue, and no issues showed up in any developer modes.
Actually, the problem was a bit bigger, and nothing to do with SecurityCheck Pro.
(This is just in case anyone else has a similar PHP8 problem on a site that is not more than a couple of years old)
I discovered that I also had a 500 error and a white page when I tried to open or create a new article. After Googling that problem, and whilst on PHP8, I reinstalled the core Joomla files, and fixed the DB – didn’t help either. Then I got the bright idea to go and check my Updates Sites. There I found that my JCE Editor Pro update site was switched off. Once switched back on I was able to update that component and all my problems went away.
Have a great weekend, all.

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #8874 by Jose
Replied by Jose on topic PHP8 Weird little problem
I'm glad to hear to sorted the other issue out. 

In some sites the change to PHP8 requires some extra steps as not all the extensions/templates are ready for it.

You can send me administrative credentials to access to the backend and check what's happening with Securitycheck Pro. Use the email from which you receive forum notifications.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • Dimps1
  • Dimps1's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
2 weeks 3 days ago #8877 by Dimps1
Replied by Dimps1 on topic PHP8 Weird little problem
No, Jose... ALL the problems were sorted out by that JCE Editor Pro upgrade.. go figure :) That means the SecurityCheck Pro issues as well. Funny that the SCP issues were only on two pages in your component.
Have a great weekend.

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #8878 by Jose
Replied by Jose on topic PHP8 Weird little problem
Ahhhhh, ok! I misunderstood you 

Have a great weekend you too!

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum

Login or Sign In