Menu

Topic-icon Column Sort in Log View issues

  • shibumi
  • shibumi's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
3 weeks 5 days ago #8679 by shibumi
Column Sort in Log View issues was created by shibumi
I've noticed that when you are in the View Web Firewall Logs section, the only column you can sort by is the Time column - clicking on any other column only reloads the Time column sort...

Also, the latest update once again wiped my Lists - they are all empty.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #8680 by Jose
Replied by Jose on topic Column Sort in Log View issues
Hi shibumi,

I've noticed that when you are in the View Web Firewall Logs section, the only column you can sort by is the Time column - clicking on any other column only reloads the Time column sort...

Yes, you're right. Will solve in the next version.

Also, the latest update once again wiped my Lists - they are all empty.

I apologize for this. The main purpose of this update is to avoid cases like this. To avoid them I have created a table for blacklist and whitelist and have moved all the previous data to them (previously all ips were stored next to other configuration parameters). Did you have any error during the update? Are also other configuration parameters reset?

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • shibumi
  • shibumi's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
2 weeks 6 days ago #8685 by shibumi
Replied by shibumi on topic Column Sort in Log View issues
Hi Jose, sorry for the delay in replying... didn't notice any other issues really... the weird thing is the lists being emptied only happened on a few sites I manage, not all of them... the majority of them are on the same private server, a couple others are hosted on siteground.

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #8686 by Jose
Replied by Jose on topic Column Sort in Log View issues
Thanks for your feedback.

Despite I couldn't reproduce the issue during all my tests I think the issue was caused due to the way I stored data in previous versions. All the config and lists were stored together so if for some reason something were wrong the entire config was reset. Now every list has its own IP and I have added some extra checks to ensure that config will always be stored the right way, so this issue should never arise again.

Regarding to the column sort issue, I confirm you that it will be solved in the next version :)

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.075 seconds
Powered by Kunena Forum

Login or Sign In