Menu

Topic-icon WTF?? Latest update broke both back and front ends of my Joomla site

  • shibumi
  • shibumi's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 2 days ago #7039 by shibumi
After latest update, I get this error in the back end:

An error has occurred.
0 syntax error, unexpected '}'
Return to Control Panel

and get 404 error on front end

Please Log in or Create an account to join the conversation.

  • shibumi
  • shibumi's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 2 days ago #7040 by shibumi
Found the error...

/administrator/components/com_securitycheckpro/helpers/fakebcmath.php -> line 99
// cycle through each stored number
        for($y=0;$y<$Len2;$y++) {
            for($x=0;$x<$Len1*2;$x++)
            // add up the numbers in the diagonal fashion the lattice method uses
            @$Rema2[Floor(($x-1)/2)+1+$y]+=(int)$Rema[$y]{$x
            }
        };
Should be:
// cycle through each stored number
        for($y=0;$y<$Len2;$y++) {
            for($x=0;$x<$Len1*2;$x++)
            // add up the numbers in the diagonal fashion the lattice method uses
            @$Rema2[Floor(($x-1)/2)+1+$y]+=(int)$Rema[$y][$x];
        }

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #7041 by Jose
Hi Shibumi,

I apologize for this error. Some versions ago I adapted the extension to be fully compliant with Joomla coding standard and there was a typo in that file during conversion.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • shibumi
  • shibumi's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 month 1 day ago #7042 by shibumi
Sorry for freaking out about this last night... Lucky for me, I was able to quickly fix the problem by editing the problem file with my cPanel File Manager. Other people with less experience might not be so lucky as it completely prevents access to all sections of the backend and the front end of the website immediately after running the update... I imagine you have removed the latest update so that nobody else gets “locked” out...

Regards,

Jeff

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #7045 by Jose
Don't worry Jeff, I fully understand your frustation after the extension broke your site. Despite all the tests I do before publishing every new version I wasn't aware of this bug because that file is loaded only if some php math extensions are not installe/enabled in the site. This is why nobody but you report this (those functions are usually installed).

Anyway I fixed the bug and uploaded the modified file to current 3.1.8 version.

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.076 seconds
Powered by Kunena Forum

Login or Sign In