Menu

Topic-icon User registration fails with SecurityCheck Pro and Spam Protection plugins

  • halvarss
  • halvarss's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 10 months ago - 1 year 10 months ago #6046 by halvarss
Hi,

I faced an issue with user registration of an application. Normally it displays the registration page with user information fields. Enabling the plugins the registration page cannot be found by Joomla. I have installed Securitycheck Pro and SC Control Center. It seems that two plugins of SC Pro are causing this:
- System - Securitycheck Pro (site plugin)
- System - Securitycheck Spam Protection (site plugin)

Disabling them and the user registration works again.
Any tips how to proceed with them?

Br, Vesa

Attachments:
Last edit: 1 year 10 months ago by halvarss. Reason: detailed information

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago - 1 year 10 months ago #6047 by Jose
Hi Vesa,

The spam protection plugin doesn't allow user registration if any of this three params (username, IP and email) appear into the stopforumspam database. This is not an issue; it's how the extension works.

Securitycheck Pro has a feature to avoid registration of new admin accounts (Configuration -> Waf Configuration -> user session protection). But this is not a bug: this prevents unauthorized accounts to be created.

I think your case is the first; try not checking the username and tell me if it works. Anyway you should have a log into Securitycheck of the rule applied; is there any log?

Regards,
Jose
Last edit: 1 year 10 months ago by Jose.

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #6048 by kimbareidaho
I'm having the same issue with a user who says she doesn't have any other sites that says she is a spammer. How do we find out if they are really in this spammer database?

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #6049 by Jose
When the user registration is blocked there is a log showing the field that appears into the spam database, so please check it.

The username is usually the "most conflictive" field as it could have been used for the spammers.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • halvarss
  • halvarss's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 10 months ago #6050 by halvarss
Hi Jose,

Thanks for the quick reply. My case seems to be more complicated.

First, In stopforumspam database there is no users logged, I'm doing the first user registration when I installed SC Pro. Second, I'm not registrating a new admin account, only common user account in my application registration form, not in Joomla.

Br, Vesa

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #6051 by Jose
You're welcome Vesa!

Can you send me administrative credentials to access to the site? This way I will check what's happening.

Please, use the email from which you receive forum notifications to send me them.

Regards,
Jose

Please Log in or Create an account to join the conversation.

Time to create page: 0.127 seconds
Powered by Kunena Forum

Login or Sign In