Menu

Topic-icon Error During Installation

  • nauseous
  • nauseous's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 1 month ago #5746 by nauseous
Error During Installation was created by nauseous
Warning
JInstaller: :Install: Error SQL Index column size too large. The maximum column size is 767 bytes.
Extension Install: SQL error processing query: DB function failed with error number 1709
Index column size too large. The maximum column size is 767 bytes.
SQL =
CREATE TABLE IF NOT EXISTS `#__securitycheckpro_storage` (
`storage_key` varchar(255) NOT NULL,
`storage_value` longtext NOT NULL,
PRIMARY KEY (`storage_key`)
) ENGINE=InnoDB AUTO_INCREMENT=0;

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5747 by Jose
Replied by Jose on topic Error During Installation
Hi nauseous,

Are you updating for a previous Securitycheck Pro version? Which database and php environments are you using?

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • nauseous
  • nauseous's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 1 month ago #5749 by nauseous
Replied by nauseous on topic Error During Installation
Using MariaDB 10.1
Configuration:
innodb_file_format=barracuda
innodb_large_prefix = true
innodb_file_per_table = true
PHP v7.0
Just registered so I have the currect version of securitycheck pro

Please Log in or Create an account to join the conversation.

  • nauseous
  • nauseous's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 1 month ago #5750 by nauseous
Replied by nauseous on topic Error During Installation
Using show global variables like 'innodb_lar%'; I did verify all settings above are setup correctly and are enabled.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5751 by Jose
Replied by Jose on topic Error During Installation
Hi nauseous,

This seems to be related database collation; in the latest version I use utf8mb4_unicode_ci. Please, read this forum entry where there are some ways to fix this issue.

Regards,
Jose

Please Log in or Create an account to join the conversation.

  • nauseous
  • nauseous's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 1 month ago #5754 by nauseous
Replied by nauseous on topic Error During Installation
I believe that article is for Windows not Linux
ERROR
[ERROR] COLLATION 'utf8mb4_unicode_ci' is not valid for CHARACTER SET 'utf8'
That article is wrong, the correct setting for MariaDB 10.1 is below
collation_server=utf8mb4_unicode_ci
character_set_server=utf8mb4

Any suggestions? Maybe It just won't work on my system.

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum

Login or Sign In